PHP is among the most widely used open-source programming languages. It’s highly popular because it’s free software, which can be used to develop interactive sites such as community web portals, e-stores or online learning websites rather than static HTML-based websites. A PHP module must be available on the server where a PHP-powered website is hosted so that its PHP code can be read. Because there aren’t any license charges for such a module and the language itself provides unlimited options for the web-based apps that you create, there’re hundreds of millions of PHP-driven sites. Moreover, there’re a vast number of PHP scripts, which you can use for your websites without the need to have any coding expertise. Since there’re different PHP versions, you have to make certain that the same version that you used while developing your site is installed on the web server as well.

PHP 4 and PHP 5 Support in Shared Web Hosting

If you order a shared web hosting package from us, you will never need to speculate on whether or not your sites are compatible with the hosting platform, as multiple PHP versions are available on our servers for your convenience’s sake. The Hepsia Control Panel will permit you to pick PHP 4, 5.2, 5.3, 5.4 or 5.5 with only one single click of the mouse and if you’d like to change the current version, the update will be applied right away. In this way, many years of work on websites built with an older PHP version won’t go down the drain. Our hosting platform will even permit you to use a different version of PHP for each domain hosted in your account, which goes to say that you can run newer and older scripts simultaneously. Most web hosting companies on the marketplace offer support for one, sometimes for two versions of PHP. In contrast to them, we consider that you should be the one to choose the version that will be used by your own sites.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

Our semi-dedicated plans support multiple PHP versions, which goes to say that you’ll be able to run all the Internet apps that you’ve built over the years. The Hepsia Control Panel, which comes bundled with each single account, will allow you to enable the needed version with one single click of the mouse. You can choose between PHP 4, 5.2, 5.3, 5.4 and 5.5. In case you want to host multiple websites in one and the very same account and they have distinctive requirements referring to the web hosting environment, you’ll be able to specify a different PHP version for each of them irrespective of which version is selected for the account as a whole. This is accomplishable thanks to our custom cloud hosting platform, which permits us to run multiple PHP versions at the same time. In contrast, the great majority of hosting providers normally support one, in exceptionally rare cases – two versions.